www.Defender50th.co.uk Forum Index www.Defender50th.co.uk
The Defender 50th Owners Club and Vehicle Register
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

LED Side/indicator/brake lights

 
Post new topic   Reply to topic    www.Defender50th.co.uk Forum Index -> General Chat
View previous topic :: View next topic  
Author Message
Jonlloyd283



Joined: 16 Mar 2016
Posts: 8
Location: Lyme Regis

PostPosted: Tue May 26, 2020 11:29 am    Post subject: LED Side/indicator/brake lights Reply with quote

Hello All,

I thought it might be a useful exercise for others if I set out my experience in fitting LED side/ indicator/ brake lights to a 50th.

I ordered a set of WIPAC coloured LED lights from John Craddock (part no S6068LED). The lights arrived and seemed good quality with clear instructions.

I set about trying to find the flasher relay in the fusebox under the bonnet as per the instructions and of course there was no sign of it here or near the fuses under the dashboard. So I decided to look on this website and discovered that the relay was buried behind the fuse unit under the dashboard and required the centre console to come out to get at it. Great!

I followed the steps set out by East Coast Rover from a link in a very old previous post (copied here - http://www.eastcoastrover.com/LEDflasher.html), and it was bit fiddly but not too difficult to get the centre console out and extract the existing relay.

I replaced the relay with the new one from the kit and connected the four new indicator lights. The front ones worked and the rear ones didnít. So I decided to fit all the other lights and come back to the rear indicators. Everything else worked.

I tested the old rear indicators with the new relay and they worked. And I swapped the new rear and front indicators - still the same problem. So it was an issue with the new indicator lights themselves. At this point I decided to read the WIPAC instructions again. These included a paragraph at the end advising that Land Rover changed the polarity on connector plugs from circa 1998 onwards. I thought they canít have changed the wiring for one set of lights and not the rest, then I remembered that I was dealing with a Land Rover. So I swapped the wires on the rear indicators and hey presto they worked!

Getting the centre console back in was more fiddly than getting it out. Iíd suggest taking out the top row of fuses before trying to re-fit the console. I didnít and the upper front section of the console caught these fuses as I was trying to manoeuvre it into place and they flew in all directions.

Also, there is a spacer that goes behind the metal plate holding the fuses. You have to hold this in place as well as the bracket to which the console end is attached while screwing in the bolt that holds it all together (looking at the ECR link will make this clearer). I couldnít physically do this because I could only get one hand in the space. So I resorted to lightly supergluing the spacer to the bracket and this made it much easier to fit.

As I bonus to all this I now know why my gear selector panel doesnít light up at night and I have to guess what gear Iím in. Two little bulb units popped out of either side of the gear selector as I was pulling the console out. Both bulbs had blown.

Anyway, I hope this may help others.

Cheers, Jon
_________________
Previous V8s: Triumph Stag, 91 Transam GTA & Corvette C5
Back to top
View user's profile Send private message
V8GPC



Joined: 03 Apr 2016
Posts: 255
Location: Manchester

PostPosted: Wed May 27, 2020 5:33 am    Post subject: Reply with quote

Great Write Up Smile I have done the exact same job.

I did notice that the wiring was different, but didn't know it had changed by design, but I checked the voltage and polarity with a meter on each pair of wires as i changed them.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    www.Defender50th.co.uk Forum Index -> General Chat All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group