www.Defender50th.co.uk Forum Index www.Defender50th.co.uk
The Defender 50th Owners Club and Vehicle Register
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Engine starts and immediately stops

 
Post new topic   Reply to topic    www.Defender50th.co.uk Forum Index -> General Chat
View previous topic :: View next topic  
Author Message
gilmore



Joined: 01 Feb 2012
Posts: 122

PostPosted: Tue Oct 09, 2018 8:23 pm    Post subject: Engine starts and immediately stops Reply with quote

Hi All,
I drove by 50th yesterday with no problems. Went to start her this morning and the engine turns over fine, starts OK, then as soon as its started it cuts out. I try again and it starts, then within a second it stops. Tried several times with the same experience. Tried again this evening and it repeated the same behaviour. Any ideas?
thanks
rob
_________________
Defender 50th Anniversary Edition GB236
Mercedes ML350CDI Sport
Honda/HM CRE300X Enduro
Yamaha YZ250F MX
Montesa Cota 4RT Repsol trials
Mercedes Sprinter 315CDI LWB
Back to top
View user's profile Send private message
V8GPC



Joined: 03 Apr 2016
Posts: 230
Location: Manchester

PostPosted: Wed Oct 10, 2018 6:13 am    Post subject: Reply with quote

could be the immobiliser… have you tried the other key fob? in case the current one is faulty and not doing its job.
Back to top
View user's profile Send private message
NAS90



Joined: 24 Jul 2015
Posts: 115

PostPosted: Wed Oct 10, 2018 2:12 pm    Post subject: Reply with quote

V8GPC wrote:
could be the immobiliser… have you tried the other key fob? in case the current one is faulty and not doing its job.

+1 most likely the immbiliser
Back to top
View user's profile Send private message
gilmore



Joined: 01 Feb 2012
Posts: 122

PostPosted: Wed Oct 10, 2018 2:14 pm    Post subject: Reply with quote

Thanks. The immobilizer appears to switch off OK. The indicators flash and the dashboard red light stops flashing - so I think we are OK there.

Interestingly I charged the battery overnight and she started up fine this morning. I wonder if the battery is on its way out. Maybe it's got enough power to turn the engine over and get it to fire, but not enough to sustain the right voltage for the electronics?
Any comments?

Anyway I'll try a new battery. The old one has been in for about 5 years so must be due.
cheers
rob
_________________
Defender 50th Anniversary Edition GB236
Mercedes ML350CDI Sport
Honda/HM CRE300X Enduro
Yamaha YZ250F MX
Montesa Cota 4RT Repsol trials
Mercedes Sprinter 315CDI LWB
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    www.Defender50th.co.uk Forum Index -> General Chat All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © phpBB Group